Art. para Webmasters y Joomla!


Logo de Net & Software (N&S)

Net And Software

Google PlusSkype netandsoftwareRSSTwitterTeléfono: (+34) 950 030 727 ✆  
Lunes a Viernes: 10h - 13h ; 17h - 20h   

Creación y Diseño de Páginas Web

Soporte, Desarrollo y Soluciones Joomla!®

Lun02Jun2014

Comprensión media

 

La opción más recomendable: Joomla! 3.x

Todavía hay gente que pregunta sobre la idoneidad de instalar Joomla! 3.3 o Joomla! 2.5. Pero estamos en el momento en el que ya no existe esa duda.

Joomla! 3.3

Joomla! 3.3.0 es la opción a instalar más adecuada en más del 99,9% de los casos. No sólo es estable, si no que es la opción más estable y optimizada de cuantas versiones se hayan sacado de Joomla! hasta el momento. En breve tendremos disponible Joomla! 3.3.1, que seguirá siendo la opción recomendable.

Hay que recordar que Joomla! 3.3 tiene un proceso muy sencillo de instalación en tan sólo unos clics, con una interfaz en nuestro propio idioma.

 

¿Por qué ya no se debe instalar Joomla! 2.5.x?

joomla! 2.5Es una pregunta muy sencilla. Joomla! 2.5 tiene soporte hasta diciembre de este año, por lo que será esa fecha la fecha límite para migrar a Joomla! 3.3 para mantener el nivel de seguridad adecuado. Instalar Joomla! 2.5 no tiene sentido en casi ningún caso ya que:

  • no existirá continuidad de soporte más allá de final de 2014;
  • no tiene las nuevas características de Joomla! 3.x;
  • es más lento, ya que su código no está optimizado como lo está Joomla! 3.3;
  • la mayoría de las extensiones ya son compatibles con Joomla! 3.x

 

Migración o permanencia

Pero el tema más caliente es cuando ya tenemos un Joomla! 2.5.x y queremos migrar a la novísima versión 3.x de Joomla!.

Lo primero que debemos conocer es que todas las extensiones instaladas en nuestro Joomla! 2.5 (incluida la plantilla) tengan versión para Joomla! 3.3 o superior. Una vez comprobado este prerequisito, sólo queda ver que nuestro servidor está preparado para la nueva versión de Joomla!. Y es que Joomla! 3.3 requiere PHP 5.3.10 o superior, para poder implementar niveles de seguridad mejores.

Si todo está listo, habrá que:

  1. realizar una copia de seguridad completa de la web,
  2. actualizar todas las extensiones de Joomla!,
  3. actualizar la plantilla,
  4. y, finalmente, actualizar Joomla! en un sólo clic.

La migración de Joomla! en sí es bien sencilla y se hace desde la propia administración de Joomla! (Componentes -> Actualización de Joomla!) sin ninguna intervención manual.

 

Inquietudes

La gente podría preguntarse que no todos los hospedajes (hostings) tienen porqué cumplir los requerimientos, y que no todas las extensiones tienen porqué tener sus versiones adaptadas a Joomla! 3.x. Si bien es cierto, el requerimiento de PHP 5.3.10 es básico en un hosting. Esta versión de PHP tiene ya una antigüedad de más de 2 años. Si su hosting no cumple con este requisito (es decir, su hosting no ha actualizado el software desde hace más de dos años), pregúntese si su hosting es adecuado para usted y su seguridad. Por otro lado, existen realmente pocas extensiones que ya no tengan su versión apta para Joomla! 3.x, pero si fuese su caso, debería ponerse en contacto con el desarrollador de la extensión para saber el futuro de esa extensión. Es raro que una extensión no esté preparada ya para las nuevas versiones de Joomla!.

Inquietudes Joomla!

Existe un caso particular con VirtueMart, el software más famoso de tienda online para Joomla!, y es que todavía no existe una versión estable para Joomla! 3.3 por lo que hace difícil la migración en algunos casos. Pero debe saber que los desarrolladores de VirtueMart ya han comunicado que la nueva versión 2.6 será la pasarela entre la versión actual estable y la futura versión compatible con Joomla! 3.3. También se debe conocer que ya existe la versión 2.9 de VirtueMart que es la versión beta de la versión apta para Joomla! 3.x. Esto quiere decir que la adaptación a Joomla! 3.3 está muy cerca y ya no supone una excusa para prorrogar el estudio de la migración de su web por su webmaster antes de que termine el soporte de Joomla! 2.5 en diciembre de 2014.

Otra inquietud es saber cuánto va a durar estable Joomla! 3.x y la respuesta no puede ser más sencilla: como mínimo 2 años y medio. Pero esto es sólo oficialmente, porque se estima que la vida de Joomla! 3.3 o superior sea bastante más amplia. Si algo está claro, es que el equipo de desarrollo ha anunciado que cualquier versión en la rama 3.x será compatible hacia atrás a partir de Joomla! 3.3, lo que significa una gran estabilidad y durabilidad del código para todos aquellos sistemas que tengan esta nueva versión de Joomla!. Esto significa también que cualquiera que haya instalado Joomla! 3.3 podrá instalar cualquier versión superior de Joomla! 3.x sin problemas.

 

Las novedades

Las novedades de Joomla! 3.x ya la hemos visto en muchos artículos de este blog y en noticias de Net & Software. Artículos relacionados:

Noticias relacionadas:

 

Lo que viene (el futuro)

Joomla! 3.4.0 está previsto para finales de julio y tiene más ventajas añadidas:

  • Microdatos
  • Administración desde el frontend
  • Integración de Composer
  • Núcleo más limpio

Para verlos todos con detalle: Primeras novedades que llegarán en Joomla! 3.4.

Escribir un comentario


Código de seguridad
Refescar

Resuelva su DUDA Joomla!

Pregunte una duda a N&S. Si es sencilla, nosotros la responderemos en el menor tiempo posible, y saldrá publicada en nuestra FAQ de Joomla! 3.x
Email:
Asunto:
Pregunta FAQ Joomla! 3.x:
Pregunta de control: ¿Cuántas ruedas tiene un triciclo?

Diccionario de Internet

Explicaciones sencillas a cualquier término informático de Internet o Joomla!.

Compártelo

Suscríbete al Boletín

Boletín Mensual con un resumen de las noticias de seguridad, novedades y artículos de interés de Joomla!
Términos y Condiciones

Últimas Noticias

Últimos Artículos Blog

Web 2.0. Desarrollo Joomla! y Programación Web. Cursos Online Videoconferencia, Amplia Experiencia en Joomla!, Posicionamiento Orgánico SEO.