Artículos Generales


Logo de Net & Software (N&S)

Net And Software

Google PlusSkype netandsoftwareRSSTwitterTeléfono: (+34) 950 030 727 ✆  
Lunes a Viernes: 10h - 13h ; 17h - 20h   

Creación y Diseño de Páginas Web

Soporte, Desarrollo y Soluciones Joomla!®

Comprensión entendible

 

Aunque puede parecer una pregunta complicada, no lo es tanto. Se debe principalmente a los cambios de estrategia del proyecto que se produjo en enero de 2012 y en abril de 2014, junto a la fecha de fin de vida útil de Joomla! 2.5.x.

Los administradores de sistemas y otros usuarios finales instalaron Joomla! 2.5. Desde ese mismo momento, el equipo de producción de Joomla! explicó que esta versión de Joomla! era una versión con soporte de larga duración. A su vez se manifiesta que la próxima versión de soporte de larga duración sería Joomla! 3.5, siguiendo una nomenclatura análoga con las versiones anteriores de Joomla!:

  • Joomla! 1.5.x fue la versión de larga duración de la rama 1;
  • Joomla! 2.5.x fue la versión de larga duración de la rama 2; y,
  • por tanto, Joomla! 3.5.x sería la versión de larga duración de la rama 3.

Esta creencia se prorroga durante toda la vida de la versión 2.5 del CMS, es decir, desde enero de 2012 hasta marzo de 2014. Ya de por sí, esta nomenclatura es especialmente extraña. Si bien Ubuntu -la distribución de Linux-, (y todas sus distribuciones análogas), usan esta manera de nombrar a sus versiones, para los seguidores de Joomla! (usuarios noveles en muchos casos), fue inusual y raro. Implicó una fuerte inversión en recursos para inculcar cómo Joomla! nombraba a sus versiones, con el objetivo de que no se instalaran versiones de no convenientes (ya que la versión 3.0, por ejemplo-, era una versión para el futuro desarrollo de la versión 3.5). Net & Software se unía a esa difícil campaña de información para que la gente conociera este curioso método de nombrar a las versiones. Una vez habituados a ello, los usuarios de Joomla! se acostumbraron.

Joomla! 3.3En marzo de 2014, tras una serie de deliberaciones que se iniciaron antes de final de 2013, se anuncia el cambio de esta antigua nomenclatura de versiones de corta y larga duración -tipo Ubuntu- por una mucho más sencilla, y en la que no hay que esperar a ninguna versión especial para tener soporte de larga duración (LTS).

Para la gente que seguía Joomla!, era un gran avance, pero surgeron inconvenientes. El más evidente fue la confusión generada otra vez. Había y hay miles de sitios web que explican detalladamente qué es eso de STS y LTS en Joomla!. La costumbre durante dos largos años de que Joomla! 2.5.x tendría su continuidad lógica en Joomla! 3.5.x, y que las versiones intermedias serían versiones de testeo y prueba, hizo mella en mucha gente.

En la actualidad se mezclan las dos informaciones. Mientras que para desarrolladores y personas implicadas en el proyecto Joomla! la nueva nomenclatura de versiones añade simplicidad y practicismo al desarrollo de Joomla!, para usuarios finales y administradores sin experiencia sólo añade confusión. Nos atrevemos a decir que esta confusión se mantiene también en algunos webmasters y pequeñas webs seguidoras de Joomla!.

En N&S siempre hemos tenido claro cómo se desarrollaban las versiones de Joomla!, e intentamos difundir lo más posible esta claridad. No es fácil.

El grueso de las descargas de Joomla! se deben a usuarios con poca experiencia, y ante la avalancha de información contradictoria, la gente prefiere no probar. Otros, confundidos y esperando Joomla! 3.5, todavía aguardan a que salga esta versión de Joomla!. Desde marzo de 2014 y con la salida de Joomla! 3.2 (y posteriormente Joomla! 3.3), se hacían automáticamente versiones de larga duración, por lo que no se hace necesario esperar para migrar.

Muchos usuarios realizan búsquedas sobre la migración de sus sitios Joomla! 2.5, y leen noticias erróneas de que hay que esperar a la versión 3.5. Si no encuentran noticias posteriores en las que especifican claramente que ya no hace falta esperar, se mantendrán hasta esa versión erróneamente.

El segundo problema para que la gente no instale Joomla! 3 se debe a que la versión 2.5.x se mantiene hasta diciembre de 2014. Ello implica tranquilidad a la hora de las migraciones. El problema es que ese plazo ya acaba, y la duda de la idoneidad de la migración puede seguir existiendo.

Por supuesto, hay otros problemas añadidos para que la gente no descargue Joomla! 3, entre ellos el retraso de la disposición de VirtueMart 3, un software de tienda online ampliamente difundido. Ya se puede descargar el nuevo VirtueMart 3 -compatible con la versión 3 de Joomla!-, por lo que para aquellos que esperaban por este software, ya podrán migrar.

Estamos seguros que cuando se inicie la andadura de Joomla! 3.5 en unos meses, las descargas Joomla! 3 irán creciendo progresivamente. Quizás si se hubiera adelantado la salida de Joomla! 3.5 se hubieran ganado descargas, pero es sólo una conjetura.

Progresión LTS Antigua Progresión LTS Nueva
Joomla! 1.0 Joomla! 1.0
Joomla! 1.5 Joomla! 1.5
Joomla! 2.5 Joomla! 2.5
Joomla! 3.5 Joomla! 3.2
  Joomla! 3.3
  Joomla! 3.4

 

Escribir un comentario


Código de seguridad
Refescar

Diccionario de Internet

Explicaciones sencillas a cualquier término informático de Internet o Joomla!.

Compártelo

Suscríbete al Boletín

Boletín Mensual con un resumen de las noticias de seguridad, novedades y artículos de interés de Joomla!
Términos y Condiciones

Últimas Noticias

Últimos Artículos Blog

Web 2.0. Desarrollo Joomla! y Programación Web. Cursos Online Videoconferencia, Amplia Experiencia en Joomla!, Posicionamiento Orgánico SEO.