Vulnerabilidades y hacking de extensiones


Logo de Net & Software (N&S)

Net And Software

Google PlusSkype netandsoftwareRSSTwitterTeléfono: (+34) 950 030 727 ✆  
Lunes a Viernes: 10h - 13h ; 17h - 20h   

Creación y Diseño de Páginas Web

Soporte, Desarrollo y Soluciones Joomla!®

Nombre de la extensión Joomla!, y versión (si procede)

Componente para Joomla! 3.x y Joomla! 2.5.x: XCloner Backup for Joomla! 3.5.1

 

Tipo de vulnerabilidad detectada

Ejecución de comandos arbitraria
Exposición de contraseña
Backups expuestos a usuarios bajo ciertos permisos
Acceso remoto no autenticado a archivos de copia de seguridad con nombres fáciles de adivinar
Acceso remoto autentificado a archivos
Contraseña MYSQL expuesta

 

Descripción

Los problemas de seguridad respecto a esta versión de este software, son múltiples: desde variables no filtradas hasta accesos a las copias de seguridad a personas con ciertos niveles de permisos. Al ser un software de backup (copias de seguridad), hace que la posibilidad al acceso a estas copias de la web cree alta inseguridad. No queremos dar más detalles del código vulnerable.

Fueron detectados el día 17 de octubre de 2014. Avisado el desarrollador, el día 28 del mismo mes se sacó una nueva versión.

Por favor, vea la sección de Desarrollo y Corrección.

 

Archivos afectados (si procede)

  • Múltiples

 

Persona, hacker u organización que ha descubierto la vulnerabilidad

Larry W. Cashdollar

 

Desarrollo y Corrección

Hay una nueva versión, la 3.5.2, que corrige TODOS los problemas de seguridad detectados. Se recomienda encarecidamente actualizar XCloner a la versión 3.5.2 lo antes posible.

 

Notas

Todas las vulnerabilidades de las extensiones de Joomla! expuestas en Net&Software, pueden estar ya corregidas con las últimas versiones de las extensiones del desarrollador. Puede ponerse siempre en contacto con los programadores del proyecto para informarse sobre esta vulnerabilidad.

Existe otra lista de extensiones vulnerables más amplia -aunque menos actualizada- en joomla.org.

Net&Software intenta que la información aquí expuesta sea lo más fidedigna posible pero no facilitará, en ningún caso, el código vulnerable. Sólo ofrecerá una información orientativa de la vulnerabilidad, excepto al desarrollador de la aplicación, si lo solicita.

Compártelo

Suscríbete al Boletín

Boletín Mensual con un resumen de las noticias de seguridad, novedades y artículos de interés de Joomla!
Términos y Condiciones

Últimas Noticias

Últimos Artículos Blog

Web 2.0. Desarrollo Joomla! y Programación Web. Cursos Online Videoconferencia, Amplia Experiencia en Joomla!, Posicionamiento Orgánico SEO.